博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
zcmu 1041
阅读量:5236 次
发布时间:2019-06-14

本文共 921 字,大约阅读时间需要 3 分钟。

1041: 二哥的困惑 Ⅳ

Description

 

A Fibonacci sequence is calculated by adding the previous two members of the sequence, with the first two members being both 1.

f(1) = 1, f(2) = 1, f(n > 2) = f(n - 1) + f(n - 2)

Your task is to take a number as input, and print that Fibonacci number.

Input

Input contains several cases, every case contains a positive integer number N.

Output

print the Nth Fibonacci number.

Sample Input

100

Sample Output

354224848179261915075
 
思路:数值太大,直接用Java大数处理。
代码如下:
import java.math.BigInteger;
import java.util.Scanner;
public class Main{
    public static void main(String args[]) {
        Scanner in = new Scanner(System.in);
        int n;
        BigInteger a[] = new BigInteger[1005];
        while(in.hasNext()) {
            n = in.nextInt();
            a[1] = BigInteger.valueOf(1);
            a[2] = BigInteger.valueOf(1);
            for(int i = 3;i <= n;i++) {
                a[i] = a[i-1].add(a[i-2]);
            }
            System.out.println(a[n]);
        }
    }
}

转载于:https://www.cnblogs.com/banyouxia/p/9412015.html

你可能感兴趣的文章
编程面试的10大算法概念汇总
查看>>
Vue
查看>>
python-三级菜单和购物车程序
查看>>
条件断点 符号断点
查看>>
VMware12 + Ubuntu16.04 虚拟磁盘扩容
查看>>
水平垂直居中
查看>>
MySQL简介
查看>>
设计模式之桥接模式(Bridge)
查看>>
jquery的$(document).ready()和onload的加载顺序
查看>>
Python Web框架Django (五)
查看>>
.net学习之继承、里氏替换原则LSP、虚方法、多态、抽象类、Equals方法、接口、装箱拆箱、字符串------(转)...
查看>>
【codevs1033】 蚯蚓的游戏问题
查看>>
【程序执行原理】
查看>>
python的多行注释
查看>>
连接Oracle需要jar包和javadoc文档的下载
查看>>
UVA 10976 - Fractions Again?!
查看>>
Dreamweaver cc新版本css单行显示
查看>>
【android】安卓的权限提示及版本相关
查看>>
JavaScript可否多线程? 深入理解JavaScript定时机制
查看>>
IOS基础学习
查看>>